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Section 3 – Laying Out Structures 
Section Goals: 
 How to Set Drainage Options 
 When to Set Structure Settings 
 Using Preference Sets 
 Laying Out Ditch Inlets 
 Laying Out a connecting Pipe 
 Saving the Drainage File 

Types of Settings 
 The Drainage database has a data model for each of the drainage structures types it 
models.  Pipes, for example, have over 70 storable attributes, inlets over sixty.  Obviously 
Laying Out structures would be a very slow process if the user had to answer fifty 
questions per structure.  Typically, some attributes of a structure type remain fairly 
constant in an office or on a project.  These “Default Settings” are known as Drainage 
Options.  Other data varies for every instance of a structure.  .  When Laying Out 
structures, S&S only asks the users for the most volatile information, which we will refer 
to as Interactive Settings.  Settings not specifically asked for during placement are taken 
from the active Drainage Settings.  

Drainage Options 
In implementing the Storm & Sanitary data architecture, Bentley chose to save the more 
common and static data in support files.  For example, office-, region- or project-wide 
settings that rarely change are set up in the civil.ini Preference File.  This data is easily 
modified by the user, but it provides a common starting point from which to start, and can 
be thought of as Default Settings.  The Preference file also contains settings which point 
to other function-specific support files, such as structure definition files and Intensity-
Duration-Frequency tables. 
 
Note: Drainage Options are not automatically displayed during placement; it is a very 
good idea to explicitly verify these settings before Laying Out structures. 
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The Drainage Options form provides 
access to most of the “Default 
Settings.”  These settings are stored in 
the Preference file (civil.ini).  Some 
settings merely point to another content 
-specific file, such as the Drainage 
Structure (structure sizes) file.  
 
The default options are segregated into 
General, Design, and structure-specific 
tabs. 

 
 

Interactive Settings 
Some structure-specific information, such as inlet location, cannot (and should not) be 
saved ahead of time.  This information must be input by the user during Lay Out of the 
Structure.  These highly variable Interactive Settings appear on the Lay Out form for each 
structure. 
 

 It is a good idea to understand every control on a Layout form.  It is easier to set it 
right during placement than it is to go back and edit it later in the workflow. 
 
Other fields in the structure model cannot be set until later in the workflow when other 
information is provided, such as flow information.   
 

Goal 1 – Reviewing/Setting General Drainage Options 
Most general settings are stored as settings in the Preference file, which, depending on 
your office standards, generally conforms to a filename of civ*.ini.  Bentley delivers two 
defaults: civil_dgn.ini for MicroStation and civil_dwg.ini for AutoCAD.  For our lab, we 
will use civ82_dgn.ini, which should be located in the project directory. 
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1. Verify that civ82_dgn.ini is the active Preference file. 
 

2. Select SC>Tools>Drainage>Options>>General.  
 
Note:  do not confuse the general SelectCAD Options (SC>Tools>Options  ) with the 

Drainage Options (SC>Tools>Drainage>Options  ).  The icons are similar, but the 
Drainage Options, like some other S&S-specific icons have a database symbol in the 
icon. 
 
The Drainage Options form is invoked.  The General and Design tabs tend to contain 
information that changes infrequently.  Nonetheless, a quick check will only enhance 
quality. 
 
3. Verify the settings are appropriate.   
4. Make sure that Status is set to “Fixed”. 
 

  
Drainage Options form, General tab Drainage Options form, Structure ID’s tab 
 
5. Select the Structure IDs tab.  
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6. Verify the structure Prefixes and Counters are appropriate.   
7. If Area and Zone Prefixes are not set to “Adrain” and “Zsan”, respectively, 

correct the Prefixes and hit “Apply”. 
 
Note: “Areas” refer to Storm Drainage rainfall basin and “Zones” refer to Sanitary 
density zones.  These data are stored in separate data structures. 
 
8. Select the “Styles” tab and review the objects underneath.  This is where 

InRoads/SelectCAD Feature Styles are set for the S&S structures. 
9. Select the “Design” tab.   
10. Review the Design settings for each Structure type by clicking on each item in the 

“Structure:” list. 
 
 
 

  
Drainage Options form, Styles tab Drainage Options form, Drainage  tab 
 
Design settings for each structure types are set through this Design tab and the respective 
Structure type. 
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The remaining tabs are for setting defaults for each structure type.  We will review these 
before Laying Out each structure. 
 
11. Close the Drainage Options form. 

Goal 2 – Setting Inlet Options 
The first step in laying out a structure is to make sure that S&S Design and Structure 
Defaults Settings are set properly.  General settings, such as Discharge Units or 
Hydraulic Equation, seldom change.  Other settings, such as Pipe Sizes and Inlet Types, 
tend to change many times within a sewer network. 
 
In this lab we will place two Grate Inlets in Sump condition along the centerline of the 
inverted-crown Balcony Rd.  We will also place a pipe between these two Inlets.  Before 
doing so we set the “default” settings of the inlets and the pipes. 
 

12. Select SC>Tools>Drainage>Options.  
13. Select the Inlet tab of the Drainage Options form. 
14. The active Inlet Information is displayed, which may or may not be appropriate 

for the structures we are Laying Out.   
15. Click on the Design tab.   
16. Click on “Inlet” in the “Structure:” list. 
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Default Inlet settings under the Inlet tab Default Inlet settings under the Design tab 
 

 Rather than change each individual setting individually, which requires attention to 
detail, many steps, and is subject to error after many changes to structures, let us see if an 
appropriate Preference Set is set up: 
 
17. Select the Preference…  button. 
 
The Preference form is invoked, displaying the previously-defined Preference Sets for the 
Drainage Options Dialog box. 
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18. Select the Preference Named “grate-sump-xl”. 
19. Click “Load” to load the settings previously defined in this Preference. 
20. “Close” the Preference form. 
 
Note: ALL the settable options in the form (not just the those visible under the active tab) 
are reset as per the Preference Set values. 
 

  
Inlet Settings, defined by “grate-sump-xl” Inlet Design Settings, defined by “grate-sump-xl” 
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As part of an interactive class we will go over each item on the form.  If you are going 
through this Manual without an instructor, hit the Help button for explanation of each 
object. 
 

 Management Hint:  For relatively static settings, individually changing settings 
every time leads to greater rework and chances for random errors.  Appropriate 
Preference Sets minimize rework and changes for random errors.  Changes to incorrect or 
non-existent Preference Sets should be saved as a new Preference Set and sent to the 
“Standards Manager” for review and inclusion into the software standards. 
 

Note: ALL the settable options in the form (not just the those visible under the active 
tab) are reset as per the Preference Set values. 
 
21. Verify the information in the form matches that shown above. 
22. If you make any necessary changes, hit Apply. 
23. “Close” the form. 

Goal 3 – Laying Out Sump Grates 
 
Now that we have set up our Grate Inlet defaults, let's place them. 
In our dataset we will place two Grate inlets at sump locations along the centerline of the 
inverted-crown Balcony Rd.  The leaders are linestrings that can be snapped to for 
“exact” placement. 
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24. Select SC>Drainage>Lay Out  
 
The “Pipe” tab is displayed by default. 

 
 

The Inlet tab of the Drainage Lay Out Form 
25. Select the “Inlet” tab. 

Inlet ID 
The “Inlet ID” value is derived from the 
settings defined in the Drainage Options 
form, General tab.  Duplicate ID's are not 
allowed.  The number is incremented to the 
next available number. 
 
Note: any default offered by the SelectCAD 
products is editable if it is in a text (or 
keyin) field. 
 

Location Frame 
The Location frame contains Northing, 
Easting, and [Inlet] Elevation key-in fields.  

A locator button to the right of these 
fields allows the user to use select the 
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location via a MicroStation Data Point <D> or Tentative Snap <T>.   
 
If the point lies within the active surface the Elevation is read from the surface.  If the 
point does not lie within the surface it reads the elevation from the active Z (which can be 
arbitrary) or from the elevation of the tentative point <T>.   
 

Connecting Pipes Frame 
Pipes can be added between inlets automatically if the toggle is selected.  This is a speed 
tool and will addressed towards the end of the class. 
 

Other Objects 
“Angle:” refers to the placement angle of the structure (subject to defaults in Drainage 
Options>>Inlets: Absolute Angle; Parallel to Alignment, Perpendicular Alignment). 
 
“Longitudinal Slope:” and “Transverse Slope:” are used for gutter flow depth and spread 
calculations (subject to defaults in Drainage Options>>Inlets) and are more important for 
on-grade inlets. 
 
The “Style… ” button is a shortcut to the Drainage Option form, Styles tab, from which 
the active structure type (Inlet) Feature Style (and correspondingly, symbology) can be 
set.  This is discussed in more detail in Chapter 3. 
 
The “Options… ” button is a shortcut to the structure-specific tab on the Drainage Option 
form.  This button makes it very easy to verify active Structure Settings before actually 
Laying Out the structure. 
 
For this exercise, we are only concerned with the Location of the Inlet. 
 

26. Click the Locator button to the right of the Northing, Easting, and Elevation 
fields. 

27. Snap to the end of the “Grate Sump 1” leader. 
28. Accept the location of the tentative point <T>. 
 
The form should return looking similar to the screenshot below: 
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29. Hit Apply. 
 

The inlet is placed.  
 
30. Click on the Locator button again. 
 
The Inlet ID is automatically incremented and the form disappears so that you can select 
the end of the leader at “Grate Sump 2”. 
 
31. Snap to the end of the leader at “Grate Sump 2”. 
32. Hit Apply. 
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The second Inlet (IN2) is placed.  
 

Goal 4 – Laying Out Pipe 
33. If the Lay Out Drainage form was NOT dismissed, simply select the “Pipe” tab to 

see the Pipe Lay Out controls. 
34. If the Lay Out Drainage form was dismissed, select SC>Drainage>Lay 

Out>>Pipe. 
 

 
 

 Before Laying Out a different type of structure it is always a good idea to check the 
structure defaults. 
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35. Select the Options button. 
 

 
 
We want to place 12” diameter PVC pipe with 4 feet of cover. 
 
36. Change pipe “Material:” to PVC. 
37. Change pipe “Size (W x T):” to 12.00 x 0.7900 
38. Change “Minimum Cover:” to 4.00 
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Although the Pipe Size will be subject to frequent changes, let us nonetheless save a 
Preference Set for PVC pipes. 
 
39. Click the “Preferences… ” button. 
40. In the Preferences dialog box, click the “Save As” button. 
41. Key in “Pipe-PVC” in the preference “Name field. 
 

 
 
42. Click “OK”. 
43. Close the Preference form. 
44. Close the Drainage Options form. 
 
We are now ready to Lay Out Pipes.  We will connect a pipe from Inlet 1 (IN1) to the 
Inlet 2 (IN2) and a pipe from IN2 to a free-exit position (similar to an outfall pipe). 
 
45. Select SC>Drainage>Lay Out>>Pipe 
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Drainage Lay Out form, Pipe Information 
Pipe ID’s 
The “Pipe ID” value is derived from the settings defined in the Drainage 
Options>>General form.  Duplicate ID's are not allowed.  The number is incremented to 
the next available number. 

Pipe Connections 
Upstream and Downstream 
Storm&Sanitary pipe layout is relatively flexible, but has one strict definition: Upstream 
and Downstream are defined from flow direction.  You can define the Upstream and 
Downstream in either order and you can have Upstream inverts lower than the 
Downstream (adverse slope), but if you accidentally define the Upstream structure as the 
Downstream structure, S&S assumes that you know what your doing and lets you.  The 
flow will ALWAYS be from UP to Down.  The error may not show up until you Design 
your system. 
 

Connecting to Structures vs. Free Entrance/Exit 
The Location frame behaves like the location frame under inlets.  The Locator buttons 
function the same but there are two per pipe end.  Pipe ends can be either attached to a 

structure or be “free.”  Use the Locator button adjacent to the ID fields,  , if you want 
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to select a structure and the Locator button adjacent to the Northing and Easting fields, 

 ,if you want to define the location of a free end. 
 
Locator buttons adjacent to Structure (ID) or Northing/Easting fields make selecting 
either a structure or a free-entrance/exit a click of a button. 
 

Butt-to-Butt Connections and Laterals 
Free-entrance and Free-exit Pipe ends (or “nodes”) can later be attached to other 
structures, including pipes (for butt-to-butt connections).  The free end has Northing, 
Easting and Elevation data stored in the database. 
 
Selecting the Lateral Connection toggle allows the pipe to discharge into another pipe.  
The collecting pipe is broken in two to allow modeling the additional flow (from the 
lateral). 

Inverts 
The remaining three fields are used to give the pipe invert/soffit elevations and slope.  
One field is derived from the other two.  Clicking a radio button locks the corresponding 
value.  Keying in a value in one of the remaining fields causes a recalculation in the 
other. 
 
By default, invert elevations are used for pipe elevation input.  With the “Use Soffit 
Elevations” checkbox Checked (ON), soffit elevations can be used. 
 

46. Select the Locator button  to the right of the Upstream ID field. 
47. Select the first upstream inlet, IN1, with a data button <D> (a snap/tentative 

point<T> to the structure is not necessary). 
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The Lay Out form returns with “IN1” in the Upstream ID field and the “Invert In:” field 
containing a default elevation derived from: 

the surface elevation - the minimum cover - the pipe diameter.   
 

The Northing and Easting fields display the structure's Northing and Easting values.  Free 
Entrance/Exit pipes will display “FREE_EXT” in the “ID” Field.. 
 

48. Select the Locator button  to the right of the Downstream ID field. 
49. Select the first Downstream inlet, IN2, with a data button <D>  
 
The form returns with the “IN2” in the Downstream ID field, a default value for “Invert 
Out:”, and a value for slope.   
 
The “Invert Out:” default value = the lower value of the  
       surface elevation - the minimum cover - the pipe diameter 
– -OR- 
–  (the upstream invert – (the minimum slope * the pipe length)). 
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50. Click “Apply” to Place the pipe. 
 
The Pipe graphic is placed and a Pipe record is added to the drainage “database.”   
 

 
 
The Layout form is updated so that the “Pipe ID:” is incremented and the Upstream 
structure is set to the Downstream structure of the previous pipe.  The default “Invert In:” 
is the lowest invert of the upstream structure minus the “Drop Across:” field in the 
structure Drainage Option tab. 
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For the pipe P2 we will give it a free-exit. 
 
51. Click on the Locator button to the right of the Downstream Northing and Easting. 
52. Snap to the left end of the centerline for Balcony Road. 
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Notice the slope is negative (positive is defined as downhill).  Notice also the prompt in 
the Lay Out form stating that the “Water [is] flowing against slope”.   
 
The “Invert Out:” default is from the elevation of the tentative point, which is at-grade.  
Rather that accept this default, we will define the pipe slope. 
 
53. Key in “1%” or “0.01” in the slope field.  The “Invert Out:” will be recalculated. 
54. Hit Apply. 
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55. The pipe is placed. 
 

 
 
Now that some work has been done, it is a good idea to save the Drainage file. 
 
56. Select SC>File>Save>Drainage Data. 
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